حل مشکل و خطای جی کوئری پس از آپدیت وردپرس

4

حل مشکل و خطای جی کوئری در وردپرس 5.6

وردپرس 5.6 با خود تغییرات مثبت متعددی را به همراه داشت. برخی از این تغییرات شامل بهبود هایی در نحوه رفتار و کارکرد بلاک ادیتور وردپرس، سازگاری با پی اچ پی 8.0، اضافه شدن قالب جدید پیشفرض دو هزار و بیست و یک و سر انجام آپدیت کتابخانه جی کوئری است. تغییر آخر یعنی تغییر ورژن جی کوئری بخشی از مجموعه تغییراتی است که از وردپرس 5.5 آغاز شده و تا وردپرس 5.7 به شرح زیر ادامه خواهد داشت :

وردپرس 5.5 : حذف اسکریپت jQuery Migrate 1.x
وردپرس 5.6 : آپدیت jQuery, jQuery UI و jQuery Migrate به نسخه های جدید
وردپرس 5.7 : حذف اسکریپت jQuery Migrate

اگر در حال مطالعه این مقاله هستید احتمالا شما هم جزو آن دسته افرادی هستید که با آپدیت به وردپرس 5.6 بخشی از سایتتان، مثلا منو ها، پنل تنظیمات قالب و یا بخش های دیگری از آن (نحوه کارکرد افزونه ها و …) دچار مشکل شده و دیگر کار نمیکنند. (جهت بررسی علت مشکل و اطمینان از اینکه این مسئله از جی کوئری ناشی شده، میتوانید کنسول مرورگر را بررسی کنید اگر مشکل شما به علت عدم تطابق ورژن جی کوئری باشد، خواهید دید که چندین و چند خطا در توابع جی کوئری به کار رفته سایت خود دریافت کرده اید.) دلیل این مسئله ناسازگاری نحوه پیاده سازی توابع قالب و افزونه های شما با نسخه جدید جی کوئری ارائه شده در وردپرس است و راه حل منطقی آن چیزی جز آپدیت قالب ها و افزونه های شما نخواهد بود.

اما بدیهی است که آپدیت قالب ها و افزونه های یک سایت آن هم در زمانی بسیار کوتاه ممکن است برای همه ما امکان پذیر نباشد. بنابراین قصد داریم در این مقاله کوتاه نحوه حل مشکل کار نکردن منو ها و بخش های دیگر سایت به علت عدم سازگاری با ورژن جی کوئری وردپرس را به شما آموزش بدهیم. از شما دعوت میکنیم در ادامه با مسترکد همراه شوید.

حل مشکل جی کوئری پس از آپدیت وردپرس

پیش از ادامه این بخش از آموزش مد نظر داشته باشید که راه حل صحیح و اساسی رفع مشکلات جی کوئری در وردپرس 5.5، 5.6 و 5.7 آپدیت قالب و افزونه های سایتتان و سازگار کردن آنها با نسخه جدید جی کوئری است. چرا که نسخه قدیمی جی کوئری وردپرس از سال 2016 به روز رسانی نشده و استفاده از آن توصیه نمیشود.

بنابراین به این آموزش به چشم یک راه حل موقت جهت دست یافتن به زمان کافی برای به روزرسانی محتوا و توابع وبسایت و افزونه های خود نگاه کنید.

جهت رفع مشکل کافی است افزونه Enable jQuery Migrate Helper را در سایت خود نصب کرده و فعال نمایید. (آموزش نصب افزونه در وردپرس)

پس از نصب افزونه، در ناحیه مدیریت وردپرس از منوی ابزارها به زیرمنوی jQuery Migrate مراجعه کنید.

تنظیمات افزونه jquery migrate helper و داونگرید ورژن جی کوئری در وردپرس

مطابق تصویر بالا jQuery Version را روی حالت Legacy قرار داده و سپس تنظیمات را ذخیره کنید. در ادامه اگر از افزونه کش در سایت خود استفاده میکنید، کش را خالی کرده (هم کش افزونه و هم کش مرورگر خود) و کارکرد بخشی که به علت عدم سازگاری با ورژن جی کوئری دچار مشکل شده بوده را مجددا بررسی کنید.

سخن آخر

در آخر مجددا تاکید میکنیم که این روش فقط راه حلی موقت است تا بتوانید زمان مورد نیاز را برای به روز رسانی و تطابق سایتتان با آخرین نسخه وردپرس و جی کوئری ارائه شده به همراه آن بدست بیاورید. بنابراین از استفاده از این روش به عنوان یک راه حل دائمی پرهیز کرده و به هیچ عنوان صورت مسئله را پاک نکنید.

دسترسی آسان به این مطلب لینک کوتاه :
QR Code For:  حل مشکل و خطای جی کوئری پس از آپدیت وردپرس
شاید از اینها هم خوشتان بیاید!
4 دیدگاه
  1. شمس می گوید

    سلام. من در داشبورد وردپرس دچار مشکل شدم و نه افزونه ها و قالب. اونو باید چکار کنم؟

    1. MrCode می گوید

      سلام
      خود داشبورد خام وردپرس که نمیتونه با ورژن جی کوئری خود وردپرس مشکل داشته باشه.
      باید ببینید بخشی که توش دچار مشکل شدید مربوط به چه افزونه یا قالبی هست.
      اگر واقعا خود داشبوردتون (بدون ارتباط به هیچ افزونه یا قالبی) به مشکل خورده باشه، احتمالا ارتباطی به این آموزش و جی کوئری نداره. احتمالا تداخلی بین افزونه ها یا قالب سایتتون با هسته وردپرس وجود داره.

  2. امیرحسین بروکلین می گوید

    با سلام و وقت بخیر، مشکلم کاملاً برطرف شد و الان قالب‌ام به خوبی کار می‌کنه و با نسخه 5.6 وردپرس هم کاملاً سازگاره، فکر می‌کردم اشکال قالب‌ام بخاطر پشتیبانی نکردن قالب از نسخه 5.6 وردپرس هست ولی با آموزش شما متوجه شدم اشکال از jQuery آپدیت شده‌ی وردپرس هست، خیلی ممنونم ازتون بابت این آموزش مفیدتون

    1. MrCode می گوید

      از اینکه مشکلتون برطرف شده خوشحالم.

ارسال پاسخ

آدرس ایمیل شما منتشر نخواهد شد.